1

Topic: win10

Anyone tried LS with win10? Am about to try this today...

LiteStep addict since b23. http://brembs.net

2

Re: win10

It looks like LS is running just fine on win10 for now. Still need to see what happens when I log out and log back in or restart the machine, but just getting LS running was easy and so far in only crashed once in the whole day.

LiteStep addict since b23. http://brembs.net

3

Re: win10

Microsoft's new browser, Edge, seems to be acting up. I have not succeeded in getting it to run on win10, yet.

LiteStep addict since b23. http://brembs.net

4

Re: win10

As usual, there are several functions that cannot be started from within LS. New and somewhat crippling is that the photo viewer does not start (error message about 'time out').

LiteStep addict since b23. http://brembs.net

5

Re: win10

Well that and the fact that you cannot set default apps without having explorer running as a shell. I am currently trying to workaround the worst issues by running explorer and litestep in parallel.

6

Re: win10

Yes, I'm also going back and forth between them, not too shabby. Had to use nDesk to get the wallpaper to show, my old desktop module wouldn't do that. So there are quite a number of cool features and apps that require explorer to work. Is there a way to get this working? Edge is not that important, but not being able to view pictures by double-clicking is pretty bad and I don't really feel like getting a separate app for picture viewing...

Also, are you using a module that displays the entire systray?

LiteStep addict since b23. http://brembs.net

7

Re: win10

Well you can use the "old" windows picture viewer - switch to explorer and set the default  viewer for photos to "windows photo viewer". I never used it because its dreadful compared to say xnview.

With Litestep as shell nTray should just "works". Icons get lost of course when you kill litestep or switch to explorer in a session.

8

Re: win10

Am trying nTray. So far, it only shows the Bluetooth icon, but the Speaker tooltip and the speaker menu, wherever I right-click on the systray. No speaker ion, though...

Does anyone have an nTray config example that works for them?

LiteStep addict since b23. http://brembs.net

9

Re: win10

Now I saw that all icons are being placed on top of each other in nTray...

LiteStep addict since b23. http://brembs.net

10

Re: win10

I also just found out the the !Shutdown bang command does not work any more.

LiteStep addict since b23. http://brembs.net

11 (edited by maka33 2015-11-27 20:25:18 pm)

Re: win10

You can look here: http://forums.litestep.info/viewtopic.php?id=416
or here: http://litestep-desktop.deviantart.com/
or even on facebook: https://www.facebook.com/litestep.shell/?fref=ts
but it works great ^_^

12

Re: win10

It seems like the deviantart group is close, i cant join. sad

13

Re: win10

Yes, I got most of it to work, but there are a few things still not working properly. But for me it's good enough. For everything that doesn't work, I just quit LS, start explorer and then do what I need to do, only to then switch back to LS. Rare enough so it doesn't bother me to much (even though it would be great if it were fixed :-)

LiteStep addict since b23. http://brembs.net

14

Re: win10

I followed the instruction that can be found here on the forum but it didn't work well at all.
I moved my post here instead.

So I did follow the instruction (or so I think) but it said i only had 32bit modules with a 64bit litestep. That and a bunch of other errors about not setting shell.
Wiped everything clean and tried to download again. Now Windows Defender say its a virus and just removes it. sad


Edit #1
Disabled WD. Reinstalled everything. Used the SetShell.exe that i could find in in the backup-folder reboot and the same error about wrong modules. And then a blank screen.

15

Re: win10

I've once written an instruction on how to install litestep manually. I still use it if something goes wrong. Works for me, but YMMV:

http://brembs.net/litestep/win2k.html

LiteStep addict since b23. http://brembs.net

16

Re: win10

What's wrong with just going with LOSI on WinXP? Or does that also work with installing on Win10 (which this topic is about)? tongue

Speaking of YMMV install guides, this has worked quite consistently on Windowses up to 8.1, heaven't heard much feedback with Win10: http://ls.greywool.com/install/

17

Re: win10

I use the by-hand method only if something like LOSI doesn't work. And yes, I found it to be quite accurate for win10 as well, so if something doesn't seem to work right on win10, it might be worth a shot to check the registry in these places.

LiteStep addict since b23. http://brembs.net

18

Re: win10

Hi. Any updates on Windows 10 Universal apps support?
I mean, will LS run them without explorer?

19

Re: win10

alexsalt wrote:

Hi. Any updates on Windows 10 Universal apps support?
I mean, will LS run them without explorer?

If by "Universal apps" you mean "metro crap", then the answer is "no", as Metro is part of explorer, not OS itself.
The only way to make it work is to write the necessary code and donate it to LiteStep core.