1 (edited by ascendancyy 2012-08-06 00:15:10 am)

Topic: Rainmeter.dll

Ok If I use the 2.1 Rainmeter .dll file I get:

LSLua - Error
Could not load luastate

If someone can help me figure out what the problem is I should be able to get what I want working.

I downloaded Rainmeter 2.0 and copied the .dll to my modules folder but I get:

Error: Could not load module.
This is likely a case of a missing C Run-Time Library or other dependency.

I have:
2005 x64
2008 x64
2008 x86
2010 x64
2010 x86

What am I missing?
Using the .dll files from Rainmeter 1.1 seem to work.

This seems to only happen If I use the 64 bit version of Rainmeter.
If I use 32 bit I get another set of problems.
If I try to use:


It is unable to find the .dll file even though it points right to it.

Rainmeter plugin C:\Program Files (x86)\Litestep\modules\rainmeter-0.12\Plugins\NowPlaying.dll not found!

Yet the file is exactly there. It only says rainmeter-0.12 so NLM won't annoy me.

2 (edited by alur 2013-08-17 13:42:26 pm)

Re: Rainmeter.dll

If you use the 64bit version, you'd need a 64bit build of LiteStep. There are no official 64bit releases right now. The architecture of the modules has to match that of the LiteStep core. (not sure why rainmeter can't find its plugin though).