1 (edited by Lucasbs 2012-12-04 16:11:37 pm)

Topic: Module downloaded, but zip was invalid.

Kinda bizarre me being the only one with this problem.
Or maybe the Search feature of this site is the problem...

"Module downloaded, but zip was invalid."

That's exactly what comes up when trying to install a theme a friend did.

There is a box (NetLoadModule: Required Modules) that gives me the opportunity to download the required module (xdesk-1.3.1).
When I press download, it 'appears' to download something for 2 seconds, and then the message comes right beside de red 'X'.

Ok, googling for xdesk-1.3.1 gave me no result but xdesk-1.3, but the message would be 'Module not found', wouldn't it ?

If it's actually a bad zip, where is it so I can delete and download it again ?
One thing I can say is that it is not on the modules folder...



Re: Module downloaded, but zip was invalid.

I tried and here, it just say, unable to download the module.
You can try to edit the theme.rc to change xdesk version hopping that rc syntax is not too much different.


Re: Module downloaded, but zip was invalid.

Unable to download ?

As I tought... it may not even exist...

Because I`ve manually dowloaded the 1.3 version, and the module was accepted without changing the step.rc

But no... the theme goes full of bugs using the 1.3 module...

Can you help me finding manually the 1.3.1 version ?

DiamondXplosion uses it on his themes.
Guess it's unofficial.


Re: Module downloaded, but zip was invalid.

No need to find the module anymore.

My friend gave it to me.

Still don't know why it ddn't download, but I guess it really isnt everywhere to find, like other modules.

If it DOESNT exists, then we have the wrong message being displayed, and then we have a bug.
But that I cannot confirm.



Re: Module downloaded, but zip was invalid.

can you send me a copy of that module version? NLM downloads from http://modules.shellfront.org/ and obviously xdesk 1.3.1 isn't there.

using LS since 1998. Old FPN site operator, owner of ShellFront, keeper of other LS domains
State of the Step 2011


Re: Module downloaded, but zip was invalid.

This is the page of the Theme:
The download link of the file is on those lattest posts.


I point you to the Theme page, so it doesn't seem I'm passing a module that is not mine.

7 (edited by Nil 2013-01-10 07:58:24 am)

Re: Module downloaded, but zip was invalid.

I have same problem. Testing my theme for a fresh instalation with a .lsz file on a new Losi install, xstatsgraph-0.8.1 is unavailable. I has put "http://www.modules.shellfront.org" on the nlm line, but then it say "the module was downloaded but the zip was invalid". All other versions of the module say the same. Is there any url i can setup in theme.rc to get the module properly ?

Maybe there's a way to host modules somewhere ?