Topic: A problem with Xtaskbar and xTray

I'm working on a new theme that uses xtaskbar 2.3.4 and it seems that every now and then, most notably with winrar the task doesn't seem to focus when you click on it. It may happen when launching from explorer but I can't really pin down the problem. As it happens with a few other applications as well.

The problem with xTray (using version 2.2.2) is that the windows processes like volume and wifi to name a couple don't seem to work at all whatsoever.

I'm using win7 x64 with the litestep installer found here and the x64 core beta files. Everything else seems to be working as expected just wondering if there's something I'm missing of if it's just the way things are for now?

Another thing on xtaskbar that would be great was if you could mimic the win7 taskbar I really miss the aero peek grouping of apps and being able to click on them. Has anyone found a workaround or another module that does this?

I've been using litestep since 97' on and off the last time I tried was with xp. Did I miss being able to customize my shell smile Glad to be back.

My first theme ever, still a WIP http://www.youtube.com/watch?v=4YYIMEuAMLI


Re: A problem with Xtaskbar and xTray

I threw together a build which "may" fix the tray icons last year xD

You can get it here: http://dl.dropbox.com/u/51925/LiteStep/ … n7patch.7z. It requires some changes to the core, so there is a new LiteStep.exe & lsapi.dll in there. Let me know if you have any problems.

I do have aero peek working in new taskbar module (nTaskbar), but it's nowhere near as feature complete as xTaskbar is yet hmm


Re: A problem with Xtaskbar and xTray

I went ahead and tested the xTray patch and it works almost perfectly, The battery Meter doesn't come up for left clicking,  Right clicking works for it though, and the Wifi  icon refuses to do anything (I got it to work once but never again). The Action Center and Volume Meter work fine with left and right clicks.

4 (edited by Nil 2013-11-10 13:49:43 pm)

Re: A problem with Xtaskbar and xTray

I have same prob with xTaskbar with windows 7 32bits. I have altap salamander that don't respond any click event and just can be accessed with alt+tab.

The fix for xtray work for volume and network icons, but all other trayicons are missing.


Re: A problem with Xtaskbar and xTray

I found why some application don't respond in xTaskbar. It happen if the task is in admin mode and litestep is not loaded as admin.