1 (edited by conlin 2013-07-13 03:30:16 am)

Topic: After upgrade 20130627 confusion

I'm very glad to have the update, but after the update, I feel all sorts of problems. Want to ask a few questions:

1. Under Windows 7 64 bit and 64 bit whether 20130627 update patch can only use http://alurcard2.net/LiteStep Modules in the Modules / 64 - bit /?

2. Under the win8 of 32 bit and 32 bit 20130627 update patch can only use nModules series modules? and I downloaded the nModule, but didn't see the readme in the package.

3. After the software update, both 32 and 64 bit, all the module has an error: in the theme could NWT load module, this is likely a case of a missing C Run Time Library - the or other dependency. But I have installed the C + + 2012.

I hope to have a list, list the main program, system, modules of collocation.

2 (edited by Lucern7 2013-08-05 15:17:41 pm)

Re: After upgrade 20130627 confusion

Sorry for replying since I can't help you but I have the same problem all the builds after 2009-4-04 do not work at all, refuse to load any modules and eventually crash litestep. I've tried installing and re-installing all runtimes and made sure I was downloading the 32 bit version. I'm using Windows 7 Ultimate.

I'd really like to know what the problem is since the newer updates seem to have some great features...


Re: After upgrade 20130627 confusion

The new alpha builds do have some issues with the older xModules and as far as I've found, none of the other modules.

If you rebuild the xModules with a newer VS, things should be working. You can grab newer builds of the xModules from here (Both 32bit and 64bit available. If you're unsure which to pick, take the 32bit ones.)

They do require Visual C++ Redistributable for Visual Studio 2013 Preview to be installed though, I believe.

If those don't help, please provide more information. Are only xModules crashing? Or other ones as well? If so, which? If you comment out all *NetLoadModule (or LoadModule) lines from the theme, does it still crash?

4 (edited by alur 2013-08-05 20:31:45 pm)

Re: After upgrade 20130627 confusion

The xModule recompiles require the visual studio 2012 runtimes, just like the core. However, the latest (2013-08-04) build may have fixed the incompatibility with the old xModules.


Re: After upgrade 20130627 confusion

You don't have to use the nModules under windows 8. However, nDesk is currently the only desktop module that renders the wallpaper on windows 8, so you might want to at least use nDesk and nCore. This should be a fairly easy change for any theme.

I don't yet ship a readme with the modules,  because the modules are still in a somewhat early stage and the readme is not done, but you can find most of the setting here: https://code.google.com/p/n-modules/wiki/Index?tm=6

Please let me know if you run into any issues configuring the modules. The wiki page is not yet complete.

Please also let me know which, if any, modules fail to load with the latest core build.


Re: After upgrade 20130627 confusion

As far as the last bit goes, I made a new copy of my old install folder, grabbed the 2013-08-04 (32bit) build from lsdev.org and shoved those files into the old litestep dir.

The results can best be described with an image:

Top left: Old build !about dialog.
Top right: New build !about dialog.
All the modules missing from the list got the error you can see at the bottom.

7 (edited by alur 2013-08-06 18:45:16 pm)

Re: After upgrade 20130627 confusion

Alright, I guess I was mistaken. I was hopeful after noticing xtaskbar-1.1.5 loaded while I was testing on XP.

The following xModule versions are neccesary to run with the latest 0.25.0 alphas:

  • xPaintClass Update 8! Nothing will load without this. Make sure you replace both the one in your modules folder and the one in your litestep folder (if you have both).

  • xStatsClass 1.1.7

  • xPopup 2.2

  • xTray 2.4

  • xTaskbar 2.3.4

  • xDesk 1.4

  • xLabel 4.4

All other modules should work fine, please let me know if anything else fails to load.


Re: After upgrade 20130627 confusion

since then, official xModules website is down, where i can grab these updated modules, please?


Re: After upgrade 20130627 confusion

Okay so I got all the right modules and it technically loads but there are a few issues

-my desktop is entirely blank, this may be because I use Jdesk instead of xdesk, but right clicking the desktop does bring up the xpopup menu
-The xtextedit, One.dll and RabidVWM modules don't load at all.

I was using xTextedit-0.5 as a primitive way of making LS remember settings through evars, and a combination of one.dll, rabidvwm-1.1.1.dll, to return window focus and type using BPtypein.dll.

There could be newer modules out there that do the same thing but I wouldn't know of them


Re: After upgrade 20130627 confusion

What operating system are you using? And what do you mean by your desktop being blank?

If you are on Windows 8, the only module which will render the wallpaper for you, at this point, is nDesk. You need to load nCore prior to nDesk. Setting for the nModules are over here: https://code.google.com/p/n-modules/wiki/Index?tm=6

I'm currently hosting them here: http://alurcard2.net/LiteStep/Modules/32bit/


Re: After upgrade 20130627 confusion

I'm using Windows 7 32bit, my desktop is blank as in none of the modules show up, ad least in the center, there's a tiny 8x8 square in the top left corner that shows the Tray icons but nothing else, no labels or anything.

They DO however show up when I downgrade to the 4-04 version... and after testing the latest version that does show the desktop the way it's meant to be is Update version 6-27-2013 any higher and I just get that little black square and nothing more. I could post a screenshot but it's not really that hard to envision...

So I guess something added after 6-27-2013 is causing an issue since the modules work fine with older builds

12 (edited by alur 2013-08-08 02:58:38 am)

Re: After upgrade 20130627 confusion

What theme are you using Lucern? To me it sounds like your configuration isn't loading properly.


Re: After upgrade 20130627 confusion

Okay you were right it was my theme, it was a thingamajig I tried whipping up myself (to get more familiar with how it's configured) and I guess I messed up somewhere I tried DiamondXplosion's "Iceflame" with the updated modules and it loaded fine.

I'll have to rewrite my theme again I guess, though if the issue could be solved that'd be quite a boon, since I'm a newb though it could be anything.


Re: After upgrade 20130627 confusion

If you were using the pre-xPC xModules, the settings changed a bit when andymon changed over to using xPC in 2005. Mostly you just need to add the PaintingMode .singlecolor or .image to your gadgets.


Re: After upgrade 20130627 confusion

Nah I've got the painting mode set and all that I'm not sure what exactly is wrong, probably something cryptic. It might have something to do with the Resolution evar though, I use ResolutionX and ResolutionY a lot to make sure it fits on all monitors, if that was changed somehow then my stuff may be off screen. 

It doesn't tell me the modules aren't properly loaded either so it's not going to be easy to find the issue and It'll probably be easier to start over.


Re: After upgrade 20130627 confusion

ResolutionX and ResolutionY should still work the same. You can always !alert "$ResolutionX$, $ResolutionY$" to verify this.


Re: After upgrade 20130627 confusion

Yeah it worked, so it's not that thanks for all the help Alur, I got it working just not for my own theme XD; It's probably for the better that I clean it up and rewrite it anyway.

Since you're working on the litestep cores I'll make a request to have a Return Window focus Bang command or perhaps have Xlabel (Or nlabel I guess) not loose focus the main window when you click on the Label.

Basically I made some typing Labels but when I click on them it attempts to type in the label since it got focus by clicking it, resulting in errors, when I want the label's bangs to affect the active window.

It'd also be neat to get autohotkey support, but this isn't really the place for requests, thanks a lot for the help and I look forward to where you take LS in the future.


Re: After upgrade 20130627 confusion

I could be wrong, but i believe in order for a program to receive keyboard input, it needs to have focus. (it's how you know where you are typing).


Re: After upgrade 20130627 confusion

Yeah exactly basically I have used that typein module to send text via a bang command for example !a sends "a". and an xLabel that when clicked Sends !a much like a virtual keyboard. The problem is when I click the label, it focuses on it rather than the window I wanted it to focus on, so I get errors since the label isn't designed to be typed in.

I had a rough way to fix (the solution here), http://litestep.net/forums/index.php?thread=1413 but it doesn't work with the newest form of litestep... Maybe BPTypeIn could be updated to handle this, if I knew coding I'd do it myself but I'm still in the learning phase.

20 (edited by DiamondXplosion 2013-08-25 00:40:39 am)

Re: After upgrade 20130627 confusion

xTextedit-0.6, comdlgls-0.7, lsxcommand-2.0.2, dont load

"Error: Could not load module.
This is likely a case of a missing C Run-Time Library or other dependency."


Re: After upgrade 20130627 confusion

Hrm, all 3 of those modules load fine for me. I use them in my own test theme.

Do they load fine for you using 0.24.8 or the 2009 0.25.0 alphas?

Also, there really should be more to that error message. I added extra details in the 2013-07-21 build.