1 (edited by Baron Bruce 2011-12-15 19:22:02 pm)

Topic: Is this normal?

I set litestep shell as default, but now when I try and quit and go explorer all I get is the file manager part, not the shell.


Re: Is this normal?

U sure your shell is set to explorer? What windows is it?


Re: Is this normal?

That's normal, explorer won't launch as a shell unless it is set as the shell.


Re: Is this normal?

Thats what I figured, however when I reset my shell to explorer it still only comes up as a file manager


Re: Is this normal?

Did you log out, and then in again, as the set shell util asks you to?
(I know it's not always needed, but it seems sometimes you have to do that)


Re: Is this normal?

Of course, by the way I should mention, I use two user accounts.
One for testing one for dev.

7 (edited by free 2011-12-18 00:13:40 am)

Re: Is this normal?

You don't have to logout/login after the shell switch.

I just have to kill my litestep with

taskkill /f /im litestep.exe

then switch the shell in the registry back to explorer.exe and launch it.


Re: Is this normal?

Actually DJ Barney mentioned something about this in #litestep yesterday. Check the value of this regkey: HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\Advanced\SeparateProcess

Do you have it at 1 or 0?

9 (edited by djbarney 2011-12-24 14:24:30 pm)

Re: Is this normal?

Yes, that's right, at least according to some testing on my system that showed that this reg key determines if explorer runs as shell or just opens a file manager window. Defined here.

EDIT: Remember to use the "Set Litestep as shell" shortcut FIRST otherwise this might not work (the reg key depends on the reg keys set by that shorcut)